Futurescale, Inc. PureMVC Home

The PureMVC Framework Code at the Speed of Thought


Over 10 years of community discussion and knowledge are maintained here as a read-only archive.

New discussions should be taken up in issues on the appropriate projects at https://github.com/PureMVC

Pages: [1]
Print
Author Topic: Using Pipes, but this one module is a blocker -- Pipe is null  (Read 3670 times)
reduxdj
Jr. Member
**
Posts: 11


View Profile Email
« on: September 02, 2009, 11:13:03 »

I can't figure out why this one module loads and then after it nothing else can load, the output is null?

<pre>
/**
       * Write the message to the connected output.
       *
       * @param message the message to write
       * @return Boolean whether any connected downpipe outputs failed
       */
      public function write( message:IPipeMessage ) : Boolean
      {
         return output.write( message );
      }

</pre>
Thanks, Patrick
      
Logged
puremvc
Global Moderator
Hero Member
*****
Posts: 2871



View Profile WWW Email
« Reply #1 on: September 02, 2009, 12:51:08 »

Probably timing (you're expecting it to be there and begin talking to it before it's loaded and connected) or the code to connect the pipe to the module didn't get executed for some reason. I suggest using the Flex Builder debugger to breakpoint the code where you connect the pipe as well as the place below where you have a trace statement now, so you can actually walk the property tree and inspect properties, even protected or private.

In the Flex Builder debugger perspective, look at the view with tabs named 'Variables', 'Breakpoints', 'Expressions', then let your eye travel to the right side of that view. There are several icons there, and you're looking for a downward pointing triangle. Click it and the menu that opens should have an item called 'Flex', click that and you should see 'Show inaccessible members'. Check that option and you'll be able to see everything.

-=Cliff>
Logged
Pages: [1]
Print