Futurescale, Inc. PureMVC Home

The PureMVC Framework Code at the Speed of Thought


Over 10 years of community discussion and knowledge are maintained here as a read-only archive.

New discussions should be taken up in issues on the appropriate projects at https://github.com/PureMVC

Pages: [1]
Print
Author Topic: FlashBuilder 4 - PureMVC + Pipes  (Read 5764 times)
klahm
Newbie
*
Posts: 1


View Profile Email
« on: April 27, 2011, 10:15:11 »

Pipes was not updated and cannot be used with SDK 4+. We are unable to upgrade our application to FlashBuilder 4. What is the recommended procedure?
Logged
puremvc
Global Moderator
Hero Member
*****
Posts: 2871



View Profile WWW Email
« Reply #1 on: April 27, 2011, 03:50:49 »

Pipes is pure Actionscript, there is no Flex dependency. What error are you getting?

-=Cliff>
Logged
Tekool
Sr. Member
****
Posts: 192


View Profile WWW Email
« Reply #2 on: April 28, 2011, 01:44:09 »

Cliff don't you think it's only a problem of regenerating .swc from sources ? Klahm is probably using a swc found directly on the download section of the website which is for any reason no more compatible with FB SDK4+.

In this case Klahm you probably have to checkout sources in Flex Builder and run a build. That's it.
Logged
puremvc
Global Moderator
Hero Member
*****
Posts: 2871



View Profile WWW Email
« Reply #3 on: April 28, 2011, 09:45:52 »

@Tek, Thought of that, but I doubt it's the case. I'm using other PureMVC utility swcs generated with FB3 in my FB4 development.

I just used PureMVC_AS3 + Utility_AS3_StateMachine in a game developed in FB4/Flex 4. No problems whatsoever. See http://dungeonjoe.com

-=Cliff>
Logged
Pages: [1]
Print