Futurescale, Inc. PureMVC Home

The PureMVC Framework Code at the Speed of Thought


Over 10 years of community discussion and knowledge are maintained here as a read-only archive.

New discussions should be taken up in issues on the appropriate projects at https://github.com/PureMVC

Pages: [1]
Print
Author Topic: Failure on dependencies  (Read 7235 times)
Peter
Full Member
***
Posts: 26


View Profile Email
« on: January 09, 2013, 04:55:27 »

Unsure if this is a bug but as soon as I add 'js' as a dependency I get an error using pub install:
Running pub install ...
Pub install failed, [1] Resolving dependencies...
Incompatible dependencies on 'unittest':
- 'js' depends on it from source 'hosted'
- 'puremvc' depends on it from source 'sdk'

If I remove puremvc as a dependency, the error goes away.
Trying 'puremvc: any' doesn't resolve the issue.

Just having:
dependencies:
#  js: any
#  unittest: any
  puremvc: any

works fine and using:

dependencies:
#  js: any
#  unittest: any
  puremvc: ">=2.0.1 <3.0.0"

also works. This btw gets me both puremvc and unittests as packages. As soon as I use:

dependencies:
  js: any
#  unittest: any
  puremvc: ">=2.0.1 <3.0.0"

I get an error:

Running pub install ...
Pub install failed, [1] Resolving dependencies...
Incompatible dependencies on 'unittest':
- 'js' depends on it from source 'hosted'
- 'puremvc' depends on it from source 'sdk'

So, does this point to puremvc declaring a dependency on unittests which causes some incompatibility?
Logged
puremvc
Global Moderator
Hero Member
*****
Posts: 2871



View Profile WWW Email
« Reply #1 on: January 09, 2013, 08:10:52 »

Alright, I think I know what this is about. I saw a post about this on G+ and tried changing the dependencies, but the latest Dart editor at the time was not pleased. I told Seth about it and he said that i should try a new project and see if I get the same issue. Unfortunately, holiday ups and downs got in the way of completing that task. I'll see if I change the deps today if it works. More on this shortly...

-=Cliff>
Logged
puremvc
Global Moderator
Hero Member
*****
Posts: 2871



View Profile WWW Email
« Reply #2 on: January 09, 2013, 08:40:34 »

So, again, I updated Dart editor to the latest as of today, and in the puremvc-dart-multicore-framework project, in the pubspec.yaml,

I CHANGED

dependencies:
   unittest:
      sdk:test

TO

dependencies:
   unittest:any

AND NOW

When I do pub install,

I GET

Could not find package "unittest 0.0.0-r14669" at http://pub.dartlang.org.

Then, from the root of the puremvc-dart-multicore-framework project, I tried removing the packages in case the old packages were in the way somehow:

rm -rf packages
rm -rf test/packages


So this is just a plain project without dependencies installed and from terminal, still, when I do pub install,

I GET

Could not find package "unittest 0.0.0-r14669" at http://pub.dartlang.org.

It seems as if something in the way the Unit Test project is setup at pub.dartlang.org.

This is everything I went through before. Seth had said to create a new app and add unittest and see if that works. And I did, and it did. So.... what gives, Dart?

More to come...
Logged
puremvc
Global Moderator
Hero Member
*****
Posts: 2871



View Profile WWW Email
« Reply #3 on: January 09, 2013, 08:46:47 »

Doh! It was pubspec.lock. Removed it and ran it again and it worked. Going to check this in and get the pubsters to pull in the new version.

Will post back here when it is done...
-=Cliff>
Logged
puremvc
Global Moderator
Hero Member
*****
Posts: 2871



View Profile WWW Email
« Reply #4 on: January 09, 2013, 09:00:13 »

Here's the request to update the hosted package on Pub.

http://code.google.com/p/dart/issues/detail?id=7796

-=Cliff>
Logged
puremvc
Global Moderator
Hero Member
*****
Posts: 2871



View Profile WWW Email
« Reply #5 on: January 09, 2013, 02:27:15 »

Alright. The update is in to pub. To pull it in, you can just follow the instructions here:
http://pub.dartlang.org/packages/puremvc

Cheers,
-=Cliff>
Logged
Peter
Full Member
***
Posts: 26


View Profile Email
« Reply #6 on: January 14, 2013, 03:27:43 »

I can now install puremvc without issues. Thanks very much for looking into this!
Logged
Pages: [1]
Print