Futurescale, Inc. PureMVC Home

The PureMVC Framework Code at the Speed of Thought


Over 10 years of community discussion and knowledge are maintained here as a read-only archive.

New discussions should be taken up in issues on the appropriate projects at https://github.com/PureMVC

Pages: 1 [2]
Print
Author Topic: sendNotification EventListener Bug  (Read 29279 times)
tobydeh
Port to Python
Sr. Member
*
Posts: 52


View Profile Email
« Reply #15 on: January 21, 2008, 09:57:45 »

Joel i do'nt think you have understood the problem

MenuMC is a movieclip of the menu.

MenuItemMC is an individual menu "button" & text etc.

The anonymous function works fine and the notification is dispatched.

The problem is that when i add children to the stage after receiving a notification they ignore their time line scripts
Logged
Joel Hooks
Courseware Beta
Sr. Member
***
Posts: 146


baby steps

 - 46288188  - passport@provinsal.com  - joeltuff
View Profile WWW Email
« Reply #16 on: January 21, 2008, 10:20:23 »

Sorry, I misread the problem. No timelines to trip me up in Flex :>
Logged

http://joelhooks.com - my ramblings about developing with actionscript and python using pureMVC and django respectively.
tobydeh
Port to Python
Sr. Member
*
Posts: 52


View Profile Email
« Reply #17 on: January 21, 2008, 10:33:24 »

Erm.. movieclips in flex have timelines.
And you have a thick kludgy pointless framework to trip you up :)
Logged
tobydeh
Port to Python
Sr. Member
*
Posts: 52


View Profile Email
« Reply #18 on: January 21, 2008, 03:34:22 »

OK... it turns out this is some sort of AS3 Bug.

Imagine the following hireachy: Stage->MenuMC->ItemMC->ButtonMC

The actionscript from the first frame of ButtonMC is being ignored. This seems to be for all children at or above level 2 (Stage being level 0)

I cannot seem to figure out what triggers this bug but it does not happen when i add the menu items BEFORE instantiating my URLLoader.

For the moment i have moved all code to frame2 which isn't a very elgant solution. Is anyone else familiar with this problem?
Logged
puremvc
Global Moderator
Hero Member
*****
Posts: 2871



View Profile WWW Email
« Reply #19 on: January 21, 2008, 10:23:01 »

He got his flex app in my flash animation, no he got his flash animation in my Flex app. Hey chill out guys and have a PureMVC flex- apimation :)

Seriously, though...

Can you duplicate the problem without the PureMVC framework?

From your description above you should be able to write simple actionscript classes that call one another that add menuMCs that exhibit this problem.

I can think of nothing in the paths through the framework that you've described that could cause this behavior.

I did not have time to test out anything today though, as it was a long workday. I did have this ugly voodoo-like gut feeling that somehow the event bubbling process might be ony going so deep or something.

-=Cliff> 
Logged
shauno


Email
« Reply #20 on: January 22, 2008, 01:34:20 »

Hi!

Yes, I've had this problem quite a bit before. I don't use flex, but I do use the Flex SDK to compile my apps. On one project, it happened consistently with every single symbol.. and I ended up doing the same nasty hack (putting my actions on frame 2 of each symbol). It hasn't happened to me lately, so I haven't bothered looking into it. I switched to the Flex3 SDK recently, so maybe that helped to solve the issue. Just a stab in the dark.

Good luck!

Cheers,
shaun.

ps. I should mention that this was happening to me way before I'd even heard of PureMVC, so it's definitely a Flex / AS3 thing.
« Last Edit: January 22, 2008, 01:35:52 by shauno » Logged
tobydeh
Port to Python
Sr. Member
*
Posts: 52


View Profile Email
« Reply #21 on: January 22, 2008, 02:21:40 »

Yeah i cant seem to pin-point what is causing this problem, it is definitely something to do with events.. somewhere.

I will investigate further when i have time.
Logged
Pages: 1 [2]
Print