I agree on the naming of the utility having become less than accurate if not downright misleading. Startup isn't completely a resource-loading-centric process, that's just a step in the overall process. There is also an alliterative conflict with the StateMachine utility name.
I'd like to propose that we branch the codebase, leaving 1.x on a branch, and from 2.0, refactor to a new name. If we're ever going to resolve this, now's a good enough time. Especially since I see you're deprecating some stuff this time. You could drop the baggage that's being carried along for backward compatibility (making the library smaller and less scary to users trying to learn it.
Any feedback on naming would be good. The shorter the better.
One thing I realize as I try to think of a suggestion for a less cumbersome name than Resource Loading Manager is that the thing has evolved quite a bit from the start. As a result there is no currently clear picture of what exactly it does and how one goes about using it and for what.
Perhaps some introductory material to the late model StartupManager after its rebirth would help suggest a name that is informing, short and not in conflict with anything else.