Futurescale, Inc. PureMVC Home

The PureMVC Framework Code at the Speed of Thought


Over 10 years of community discussion and knowledge are maintained here as a read-only archive.

New discussions should be taken up in issues on the appropriate projects at https://github.com/PureMVC

Pages: 1 [2]
Print
Author Topic: Weborb Login Sample using AMFPHP instead  (Read 10339 times)
danielcsgomes
Full Member
***
Posts: 47

 - daniel@onedesign.com.pt
View Profile Email
« Reply #15 on: September 10, 2008, 01:58:05 »

Show all your php codes and folder/file structure, let's see what is happening, but it's strange for sure :| But for me the only problem is Paths or AMFPHP configuration.

Daniel Gomes
Logged
kofiaddaquay
Full Member
***
Posts: 31


View Profile Email
« Reply #16 on: September 10, 2008, 08:14:49 »

Really appreciate the help Daniel.

so that i dont have code all over the page, i am attaching a link so you can see all the php files. its a simple structure. one service and one value object php file

http://www.scripton.net/flash/_projects/kofiamfphp.zip

Logged
danielcsgomes
Full Member
***
Posts: 47

 - daniel@onedesign.com.pt
View Profile Email
« Reply #17 on: September 11, 2008, 02:35:32 »

I found the problem.

AMFPHP, only recognize VO and Paths if the VO and the php Service file have the same structure. So you need to have it:

The LoginServiceFacade.php have to be in this directory -> services/net/scriptoninteractive/buipower/model
The LoginVO.php have to be here -> services/vo/net/scriptoninteractive/buipower/model/vo

Now you have to change all paths inside of files, it should work now.

Daniel Gomes
Logged
kofiaddaquay
Full Member
***
Posts: 31


View Profile Email
« Reply #18 on: September 11, 2008, 08:19:11 »

i have done that..but still getting the error

correlationId (String):
faultCode (String): AMFPHP_FILE_NOT_FOUND
faultDetail (String): /Users/kofiaddaquay/Sites/amfphp2/core/shared/app/BasicActions.php on line 33
faultString (String): The class {Amf3Broker} could not be found under the class path {/Users/kofiaddaquay/Sites/amfphp2/services/amfphp/Amf3Broker.php}


BUT!..i did switch over to weborb, and my login works fine against the database! this makes me happy but at the same time i am not sure if i want to use weborb. do you use it? i was under the impression that amfphp has a larger community and i can get help when i need it than when i use weborb. please advice. i dont know if i want to waste anymore time debugging amfphp when the main focus should be on the main application.

i will still spend sometime and make sure all my paths are right for amfphp to see if i can continue there...but in the mean time i will continue with weborb so i can make progress. let me know your thoughts on the above. thanks for your time Daniel..i really appreciate it.

Kofi
Logged
danielcsgomes
Full Member
***
Posts: 47

 - daniel@onedesign.com.pt
View Profile Email
« Reply #19 on: September 11, 2008, 11:24:07 »

Yes i use it, for me it's more easier to work then amfphp at least for PureMVC you don't need to have the VO in a different folder and Weborb can generate code and in the next release 3.5 you will have data management it will be a very nice feature :D

In AMFPHP it should work now, i tried and it works.

Daniel Gomes
Logged
Pages: 1 [2]
Print