Futurescale, Inc. PureMVC Home

The PureMVC Framework Code at the Speed of Thought


Over 10 years of community discussion and knowledge are maintained here as a read-only archive.

New discussions should be taken up in issues on the appropriate projects at https://github.com/PureMVC

Pages: [1]
Print
Author Topic: Weird Behavior in Flash Player 10  (Read 2952 times)
michael_ramirez44
Port to AS3
Jr. Member
*
Posts: 11


View Profile Email
« on: October 20, 2008, 12:40:27 »

I view my application with the latest Flash Player and weird things begin to happen. One thing I noticed is my mediators stop responding to notifications send by my proxies but only after I have made at least one proxy call. Has anybody else tested their applications against FP 10.
Logged
puremvc
Global Moderator
Hero Member
*****
Posts: 2871



View Profile WWW Email
« Reply #1 on: October 21, 2008, 04:50:53 »

Hi Micheal,

What do you learn by stepping through it with the febugger? Whenever something like this happens, the debugger is your best friend.

Just set a breakpoint where the Proxy sends the Notification for the first time, debug the app and trigger the send.

Then step through till it hits the Mediator to follow the path that should be taken.

Then hit the play button to set it going again and trigger the send again.

That should put you back on the Proxy, about to send. If not then whatever triggers the send has broken.

Otherwise step on through again and see where it runs off in the weeds.

Please do let us know what you find. I cannot imagine what has happened that would make the framework break.
 
-=Cliff>
Logged
Pages: [1]
Print